aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/CMakeLists.txt
diff options
context:
space:
mode:
authorjaroWMR <jarorutjes07@gmail.com>2024-10-10 07:06:11 +0200
committerjaroWMR <jarorutjes07@gmail.com>2024-10-10 07:06:11 +0200
commit3f22ea7e41a81d3c818bdeb536f8df7ff352ae0f (patch)
tree68fc72eb4c11beb5e1c304b9490fce7192d132f3 /src/crepe/CMakeLists.txt
parent97621ae53dfc3434cd97e45266bd4f4ac2ef49e1 (diff)
parent29fb4bda4872bdfe33a2416a239fb62fc0238167 (diff)
merge with master
Diffstat (limited to 'src/crepe/CMakeLists.txt')
-rw-r--r--src/crepe/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/crepe/CMakeLists.txt b/src/crepe/CMakeLists.txt
index c7f18cd..a02e991 100644
--- a/src/crepe/CMakeLists.txt
+++ b/src/crepe/CMakeLists.txt
@@ -8,6 +8,14 @@ target_sources(crepe PUBLIC
ParticleEmitter.cpp
ParticleSystem.cpp
SDLApp.cpp
+ ComponentManager.cpp
+ Component.cpp
+ GameObject.cpp
+ Collider.cpp
+ Rigidbody.cpp
+ Sprite.cpp
+ ScriptSystem.cpp
+ Script.cpp
)
target_sources(crepe PUBLIC FILE_SET HEADERS FILES
@@ -18,6 +26,16 @@ target_sources(crepe PUBLIC FILE_SET HEADERS FILES
ParticleSystem.hpp
Particle.hpp
SDLApp.hpp
+ ComponentManager.h
+ ComponentManager.hpp
+ Component.h
+ GameObject.h
+ GameObject.hpp
+ Collider.h
+ Rigidbody.h
+ Sprite.h
+ System.h
+ ScriptSystem.h
)
add_subdirectory(api)