aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 4 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9aa96ad..38d4707 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,11 +21,13 @@ else()
endif()
if(ENABLE_LTO)
- add_compile_options(-flto)
+ add_compile_options(-O3 -flto)
endif()
+add_compile_options(-fno-pic)
+add_link_options(-no-pie)
+
option(BUILD_LIBUI "Build libui frontend" ON)
-option(BUILD_SDL "Build SDL2 frontend" OFF)
add_subdirectory(src)
@@ -33,10 +35,6 @@ if (BUILD_LIBUI)
add_subdirectory(src/libui_sdl)
endif()
-if (BUILD_SDL)
- add_subdirectory(src/sdl)
-endif()
-
configure_file(
${CMAKE_SOURCE_DIR}/romlist.bin
${CMAKE_BINARY_DIR}/romlist.bin COPYONLY)