aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorArisotura <thetotalworm@gmail.com>2019-06-04 15:53:08 +0200
committerGitHub <noreply@github.com>2019-06-04 15:53:08 +0200
commit97f4b5f70b67ea5cc142fbd1f3982c36b915a5d9 (patch)
treebd3fb3325db3743eef00cf3ddffafdeb644370a9 /CMakeLists.txt
parentf769d6e23f7635910e3f6659c6b55d8c6a8e96ff (diff)
parent3134c8fc66d1fbd5706930a3e3e64ce118406fe5 (diff)
Merge branch 'master' into fast-forward-hotkey
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 4 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9aa96ad..38d4707 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,11 +21,13 @@ else()
endif()
if(ENABLE_LTO)
- add_compile_options(-flto)
+ add_compile_options(-O3 -flto)
endif()
+add_compile_options(-fno-pic)
+add_link_options(-no-pie)
+
option(BUILD_LIBUI "Build libui frontend" ON)
-option(BUILD_SDL "Build SDL2 frontend" OFF)
add_subdirectory(src)
@@ -33,10 +35,6 @@ if (BUILD_LIBUI)
add_subdirectory(src/libui_sdl)
endif()
-if (BUILD_SDL)
- add_subdirectory(src/sdl)
-endif()
-
configure_file(
${CMAKE_SOURCE_DIR}/romlist.bin
${CMAKE_BINARY_DIR}/romlist.bin COPYONLY)