aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorRSDuck <rsduck@users.noreply.github.com>2020-09-30 23:58:42 +0200
committerRSDuck <rsduck@users.noreply.github.com>2020-10-01 00:01:05 +0200
commit697730240394cd9fedcf7924f29ffa625fc784fd (patch)
tree561943f062c9b9a194c66fadad37b175a509b149 /src/CMakeLists.txt
parent4b705556bcd3eabaff608ab06b24765472745c21 (diff)
make OpenGL renderer a build option
mostly meant for the Switch port
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt31
1 files changed, 22 insertions, 9 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 8839fc2..d6c3897 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -26,17 +26,12 @@ add_library(core STATIC
FIFO.h
GBACart.cpp
GPU.cpp
- GPU_OpenGL.cpp
- GPU_OpenGL_shaders.h
GPU2D.cpp
GPU3D.cpp
- GPU3D_OpenGL.cpp
- GPU3D_OpenGL_shaders.h
GPU3D_Soft.cpp
melonDLDI.h
NDS.cpp
NDSCart.cpp
- OpenGLSupport.cpp
Platform.h
ROMList.h
RTC.cpp
@@ -52,6 +47,16 @@ add_library(core STATIC
xxhash/xxhash.c
)
+if (ENABLE_OGLRENDERER)
+ target_sources(core PRIVATE
+ GPU_OpenGL.cpp
+ GPU_OpenGL_shaders.h
+ GPU3D_OpenGL.cpp
+ GPU3D_OpenGL_shaders.h
+ OpenGLSupport.cpp
+ )
+endif()
+
if (ENABLE_JIT)
enable_language(ASM)
@@ -95,8 +100,16 @@ if (ENABLE_JIT)
endif()
endif()
-if (WIN32)
- target_link_libraries(core ole32 comctl32 ws2_32 opengl32)
+if (ENABLE_OGLRENDERER)
+ if (WIN32)
+ target_link_libraries(core ole32 comctl32 ws2_32 opengl32)
+ else()
+ target_link_libraries(core GL EGL)
+ endif()
else()
- target_link_libraries(core GL EGL)
-endif()
+ if (WIN32)
+ target_link_libraries(core ole32 comctl32 ws2_32)
+ else()
+ target_link_libraries(core)
+ endif()
+endif() \ No newline at end of file