aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crepe/CMakeLists.txt')
-rw-r--r--src/crepe/CMakeLists.txt13
1 files changed, 2 insertions, 11 deletions
diff --git a/src/crepe/CMakeLists.txt b/src/crepe/CMakeLists.txt
index ef2584e..57c77be 100644
--- a/src/crepe/CMakeLists.txt
+++ b/src/crepe/CMakeLists.txt
@@ -9,15 +9,11 @@ target_sources(crepe PUBLIC
SDLApp.cpp
ComponentManager.cpp
Component.cpp
- GameObject.cpp
- Collider.cpp
- Rigidbody.cpp
- Sprite.cpp
ScriptSystem.cpp
PhysicsSystem.cpp
Transform.cpp
- Force.cpp
CollisionSystem.cpp
+ Collider.cpp
)
target_sources(crepe PUBLIC FILE_SET HEADERS FILES
@@ -31,17 +27,12 @@ target_sources(crepe PUBLIC FILE_SET HEADERS FILES
ComponentManager.h
ComponentManager.hpp
Component.h
- GameObject.h
- GameObject.hpp
- Collider.h
- Rigidbody.h
- Sprite.h
System.h
ScriptSystem.h
PhysicsSystem.h
Transform.h
- Force.h
CollisionSystem.h
+ Collider.h
)
add_subdirectory(api)