aboutsummaryrefslogtreecommitdiff
path: root/game/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'game/CMakeLists.txt')
-rw-r--r--game/CMakeLists.txt14
1 files changed, 13 insertions, 1 deletions
diff --git a/game/CMakeLists.txt b/game/CMakeLists.txt
index 9251b2c..dec161d 100644
--- a/game/CMakeLists.txt
+++ b/game/CMakeLists.txt
@@ -7,7 +7,10 @@ set(CMAKE_BUILD_TYPE Debug)
project(game C CXX)
add_subdirectory(../src crepe)
-add_executable(main
+
+add_executable(main)
+
+add_executable(main PUBLIC
#background
background/AquariumSubScene.cpp
background/AquariumScript.cpp
@@ -43,6 +46,11 @@ add_executable(main
main.cpp
# scripts
+
+add_executable(main)
+
+target_sources(main PUBLIC
+ GameScene.cpp
MoveCameraManualyScript.cpp
StartGameScript.cpp
@@ -88,5 +96,9 @@ add_executable(main
Random.cpp
)
+add_subdirectory(background)
+add_subdirectory(prefab)
+
target_link_libraries(main PUBLIC crepe)
+target_include_directories(main PRIVATE .)