aboutsummaryrefslogtreecommitdiff
path: root/game/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'game/CMakeLists.txt')
-rw-r--r--game/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/game/CMakeLists.txt b/game/CMakeLists.txt
new file mode 100644
index 0000000..937b5e6
--- /dev/null
+++ b/game/CMakeLists.txt
@@ -0,0 +1,27 @@
+cmake_minimum_required(VERSION 3.28)
+
+set(CMAKE_C_STANDARD 11)
+set(CMAKE_CXX_STANDARD 20)
+set(CMAKE_EXPORT_COMPILE_COMMANDS 1)
+set(CMAKE_BUILD_TYPE Debug)
+
+project(game C CXX)
+
+add_subdirectory(../src crepe)
+add_executable(main
+ background/AquariumSubScene.cpp
+ background/BackgroundSubScene.cpp
+ background/ForestParallaxScript.cpp
+ background/ForestSubScene.cpp
+ GameScene.cpp
+ background/HallwaySubScene.cpp
+ MoveCameraManualyScript.cpp
+ PlayerScript.cpp
+ PlayerSubScene.cpp
+ StartGameScript.cpp
+ background/StartSubScene.cpp
+ main.cpp
+)
+
+target_link_libraries(main PUBLIC crepe)
+