aboutsummaryrefslogtreecommitdiff
path: root/src/example/CMakeLists.txt
diff options
context:
space:
mode:
authorheavydemon21 <nielsstunnebrink1@gmail.com>2024-10-23 14:00:27 +0200
committerheavydemon21 <nielsstunnebrink1@gmail.com>2024-10-23 14:00:27 +0200
commit194c8c4af559f9ea35b2fc53103415ea1e47fb61 (patch)
tree93bc71b9978ed5df5afb993f70f051ddda91a2b6 /src/example/CMakeLists.txt
parenteaa05e7a981b0f581f5393882e4753d9294a3dba (diff)
parent04a040e28ade412ea5b1767bf77eed3956121973 (diff)
Merge branch 'master' into niels/rendering
Diffstat (limited to 'src/example/CMakeLists.txt')
-rw-r--r--src/example/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/example/CMakeLists.txt b/src/example/CMakeLists.txt
index 1b148b3..7c87afc 100644
--- a/src/example/CMakeLists.txt
+++ b/src/example/CMakeLists.txt
@@ -1,3 +1,6 @@
+# all examples
+add_custom_target(examples)
+
# add_example(target_name [SOURCES...])
function(add_example target_name)
# if SOURCES is not specified
@@ -10,6 +13,7 @@ function(add_example target_name)
add_executable(${target_name} EXCLUDE_FROM_ALL ${sources})
target_link_libraries(${target_name} PUBLIC crepe)
+ add_dependencies(examples ${target_name})
endfunction()
add_example(audio_internal)