aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/api/CMakeLists.txt
diff options
context:
space:
mode:
authorWBoerenkamps <wrj.boerenkamps@student.avans.nl>2024-11-11 16:12:09 +0100
committerWBoerenkamps <wrj.boerenkamps@student.avans.nl>2024-11-11 16:12:09 +0100
commit80c74b90a3e44e25a4fa9fdd25bf0aa9efbaf6fd (patch)
tree1ac04e3434c8e775318b6f8519c6674bb2a3298d /src/crepe/api/CMakeLists.txt
parent880a7b1fb233a67303ad5a4155dc459f79734762 (diff)
interfaces working but unsubscribe broken
Diffstat (limited to 'src/crepe/api/CMakeLists.txt')
-rw-r--r--src/crepe/api/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/crepe/api/CMakeLists.txt b/src/crepe/api/CMakeLists.txt
index 87cbb09..4e8f8a0 100644
--- a/src/crepe/api/CMakeLists.txt
+++ b/src/crepe/api/CMakeLists.txt
@@ -18,6 +18,10 @@ target_sources(crepe PUBLIC
Vector2.cpp
Camera.cpp
Animator.cpp
+ EventManager.cpp
+ EventHandler.cpp
+ IKeyListener.cpp
+ IMouseListener.cpp
)
target_sources(crepe PUBLIC FILE_SET HEADERS FILES
@@ -42,4 +46,9 @@ target_sources(crepe PUBLIC FILE_SET HEADERS FILES
SceneManager.hpp
Camera.h
Animator.h
+ EventManager.h
+ EventHandler.h
+ Event.h
+ IKeyListener.h
+ IMouseListener.h
)