aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/api/CMakeLists.txt
diff options
context:
space:
mode:
authormax-001 <maxsmits21@kpnmail.nl>2024-12-05 17:25:50 +0100
committermax-001 <maxsmits21@kpnmail.nl>2024-12-05 17:25:50 +0100
commit0b942f4d6eb87fb623afbbae617478674c612ccc (patch)
tree9fd575e1793367e744b60b7d2bed626a72dc70f4 /src/crepe/api/CMakeLists.txt
parent121387ba92a23d6f17b36331d25757abc899f7d2 (diff)
parent1f4e961d7f9d6887c807cac1a362f2d178b0860b (diff)
Merge remote-tracking branch 'origin/master' into max/AI
Diffstat (limited to 'src/crepe/api/CMakeLists.txt')
-rw-r--r--src/crepe/api/CMakeLists.txt12
1 files changed, 4 insertions, 8 deletions
diff --git a/src/crepe/api/CMakeLists.txt b/src/crepe/api/CMakeLists.txt
index d42b459..0355b72 100644
--- a/src/crepe/api/CMakeLists.txt
+++ b/src/crepe/api/CMakeLists.txt
@@ -9,13 +9,10 @@ target_sources(crepe PUBLIC
Texture.cpp
AssetManager.cpp
Sprite.cpp
- SaveManager.cpp
Config.cpp
Metadata.cpp
- SceneManager.cpp
Camera.cpp
Animator.cpp
- EventManager.cpp
IKeyListener.cpp
IMouseListener.cpp
LoopManager.cpp
@@ -23,6 +20,8 @@ target_sources(crepe PUBLIC
Asset.cpp
EventHandler.cpp
Script.cpp
+ Button.cpp
+ UIObject.cpp
AI.cpp
)
@@ -42,15 +41,10 @@ target_sources(crepe PUBLIC FILE_SET HEADERS FILES
Texture.h
AssetManager.h
AssetManager.hpp
- SaveManager.h
Scene.h
Metadata.h
- SceneManager.h
- SceneManager.hpp
Camera.h
Animator.h
- EventManager.h
- EventManager.hpp
EventHandler.h
EventHandler.hpp
Event.h
@@ -59,5 +53,7 @@ target_sources(crepe PUBLIC FILE_SET HEADERS FILES
LoopManager.h
LoopTimer.h
Asset.h
+ Button.h
+ UIObject.h
AI.h
)