aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/CMakeLists.txt
diff options
context:
space:
mode:
authorLoek Le Blansch <loek@pipeframe.xyz>2024-11-05 16:12:47 +0100
committerLoek Le Blansch <loek@pipeframe.xyz>2024-11-05 16:12:47 +0100
commite36ea050972fcaaf3d85d672755bad4ebb2dcd80 (patch)
tree5145e0b66650eea1df301106b7d197a586be65f3 /src/crepe/CMakeLists.txt
parent333b07775be1ef20fdb5909672c1e4dcabec1b40 (diff)
parentb770475741b7c33d57331f3139c55a3f237ad274 (diff)
merge `master` into `loek/savemgr`loek/savemgr
Diffstat (limited to 'src/crepe/CMakeLists.txt')
-rw-r--r--src/crepe/CMakeLists.txt22
1 files changed, 2 insertions, 20 deletions
diff --git a/src/crepe/CMakeLists.txt b/src/crepe/CMakeLists.txt
index 750a47d..3b05742 100644
--- a/src/crepe/CMakeLists.txt
+++ b/src/crepe/CMakeLists.txt
@@ -1,41 +1,23 @@
target_sources(crepe PUBLIC
Asset.cpp
- Sound.cpp
- SoundContext.cpp
Particle.cpp
- ParticleSystem.cpp
- SDLApp.cpp
ComponentManager.cpp
Component.cpp
- ScriptSystem.cpp
- PhysicsSystem.cpp
- CollisionSystem.cpp
Collider.cpp
- SDLContext.cpp
- RenderSystem.cpp
- DB.cpp
)
target_sources(crepe PUBLIC FILE_SET HEADERS FILES
Asset.h
- Sound.h
- SoundContext.h
- SDLContext.h
ComponentManager.h
ComponentManager.hpp
Component.h
- System.h
- ScriptSystem.h
- PhysicsSystem.h
- CollisionSystem.h
Collider.h
- SDLContext.h
- RenderSystem.h
ValueBroker.h
ValueBroker.hpp
- DB.h
)
add_subdirectory(api)
+add_subdirectory(facade)
+add_subdirectory(system)
add_subdirectory(util)