aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/CMakeLists.txt
diff options
context:
space:
mode:
authormax-001 <maxsmits21@kpnmail.nl>2024-11-05 16:29:18 +0100
committermax-001 <maxsmits21@kpnmail.nl>2024-11-05 16:29:18 +0100
commitae6a103946e437ca85cc69c5fc2cbf68d35ffeae (patch)
treea0bd09748c68950353f05d245bed4de470548fc6 /src/crepe/CMakeLists.txt
parenta5d3564f6d051986376c98abb9c098a8a7183fe0 (diff)
parent5b248d068a94902be9ca4d00fe07d551f64c49b9 (diff)
Merge remote-tracking branch 'origin/master' into max/gameobject
Diffstat (limited to 'src/crepe/CMakeLists.txt')
-rw-r--r--src/crepe/CMakeLists.txt20
1 files changed, 2 insertions, 18 deletions
diff --git a/src/crepe/CMakeLists.txt b/src/crepe/CMakeLists.txt
index 9ad1ff9..867329f 100644
--- a/src/crepe/CMakeLists.txt
+++ b/src/crepe/CMakeLists.txt
@@ -1,39 +1,23 @@
target_sources(crepe PUBLIC
Asset.cpp
- Sound.cpp
- SoundContext.cpp
Particle.cpp
- ParticleSystem.cpp
- SDLApp.cpp
ComponentManager.cpp
Component.cpp
- ScriptSystem.cpp
- PhysicsSystem.cpp
- CollisionSystem.cpp
Collider.cpp
- SDLContext.cpp
- RenderSystem.cpp
Metadata.cpp
)
target_sources(crepe PUBLIC FILE_SET HEADERS FILES
Asset.h
- Sound.h
- SoundContext.h
- SDLContext.h
ComponentManager.h
ComponentManager.hpp
Component.h
- System.h
- ScriptSystem.h
- PhysicsSystem.h
- CollisionSystem.h
Collider.h
- SDLContext.h
- RenderSystem.h
Metadata.h
)
add_subdirectory(api)
+add_subdirectory(facade)
+add_subdirectory(system)
add_subdirectory(util)