aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorLoek Le Blansch <loek@pipeframe.xyz>2024-10-27 19:33:45 +0100
committerLoek Le Blansch <loek@pipeframe.xyz>2024-10-27 19:33:45 +0100
commitb2fc208fbdb55ecc3cba59e2dd51976ce829a4be (patch)
tree1a60e74b7533403831868b04943978987cec2c75 /src/CMakeLists.txt
parentecc5761fa78ccb57db958467c3fc999aceadd409 (diff)
WIP db facade
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index b60a0cd..de9e990 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -11,6 +11,7 @@ find_package(SDL2 REQUIRED)
find_package(SDL2_image REQUIRED)
find_package(SoLoud REQUIRED)
find_package(GTest REQUIRED)
+find_library(BERKELEY_DB db)
add_library(crepe SHARED)
add_executable(test_main EXCLUDE_FROM_ALL)
@@ -23,6 +24,7 @@ target_link_libraries(crepe
PRIVATE soloud
PUBLIC SDL2
PUBLIC SDL2_image
+ PUBLIC ${BERKELEY_DB}
)
add_subdirectory(crepe)