aboutsummaryrefslogtreecommitdiff
path: root/mwe/gameloop/CMakeLists.txt
diff options
context:
space:
mode:
authorLoek Le Blansch <loek@pipeframe.xyz>2024-09-21 15:35:05 +0200
committerLoek Le Blansch <loek@pipeframe.xyz>2024-09-21 15:35:05 +0200
commit44affb6635359ef2f619562800165ccfff438ae4 (patch)
tree4da7fa01953055740f9e668e94c59259d4d7749f /mwe/gameloop/CMakeLists.txt
parentca393b6b47618e48c107ad5c021d86700343648e (diff)
`make format`
Diffstat (limited to 'mwe/gameloop/CMakeLists.txt')
-rw-r--r--mwe/gameloop/CMakeLists.txt12
1 files changed, 5 insertions, 7 deletions
diff --git a/mwe/gameloop/CMakeLists.txt b/mwe/gameloop/CMakeLists.txt
index 6bc5017..233ba98 100644
--- a/mwe/gameloop/CMakeLists.txt
+++ b/mwe/gameloop/CMakeLists.txt
@@ -8,21 +8,19 @@ set(CMAKE_CXX_STANDARD_REQUIRED True)
# Find the SDL2 package
find_package(SDL2 REQUIRED)
-# Add your executable
-set(SOURCES
- src/loopManager
- src/window.cpp
- src/main.cpp
+add_executable(gameloop
+ src/loopManager.cpp
+ src/window.cpp
+ src/main.cpp
src/eventManager.cpp
src/gameObject.cpp
src/timer.cpp
)
-add_executable(gameloop ${SOURCES})
-
# Link the SDL2 library to your project
target_link_libraries(gameloop ${SDL2_LIBRARIES})
# Include SDL2 header files and project headers
target_include_directories(gameloop PRIVATE ${SDL2_INCLUDE_DIRS})
target_include_directories(gameloop PRIVATE ${CMAKE_SOURCE_DIR}/include)
+