aboutsummaryrefslogtreecommitdiff
path: root/client/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'client/CMakeLists.txt')
-rw-r--r--client/CMakeLists.txt16
1 files changed, 11 insertions, 5 deletions
diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
index 8c0dcf3..8d15e50 100644
--- a/client/CMakeLists.txt
+++ b/client/CMakeLists.txt
@@ -10,7 +10,6 @@ add_compile_definitions(DEBUG)
project(pbc C CXX)
-add_subdirectory(lib/mpack)
add_subdirectory(lib/i2ctcp)
add_subdirectory(lib/pbdrv)
include(lib/pbdrv/ext/stdlib/include.cmake)
@@ -24,12 +23,19 @@ add_executable(pbc
xxd.c
i2c.cpp
mod.c
- )
+)
target_link_libraries(pbc
i2ctcp
- mpack
- readline # this is such a common library that I did not bother adding it as a submodule
+
+ # this is such a common library that I did not bother adding it as a submodule
+ readline
+
+ # pbdrv-mod is used instead of pbdrv because the client generates messages
+ # that are blindly forwarded by the main controller. The message routing
+ # logic from pbdrv-mod is not used as the client is not a puzzle module, but
+ # it still uses the same PB_MOD_ADDR as the main controller to impersonate
+ # the main controller.
pbdrv-mod
- )
+)