aboutsummaryrefslogtreecommitdiff
path: root/main/CMakeLists.txt
diff options
context:
space:
mode:
authorThomasintAnker <thomasintanker1@gmail.com>2024-05-18 20:48:50 +0200
committerThomasintAnker <thomasintanker1@gmail.com>2024-05-18 20:48:50 +0200
commit56440df6b9810dbbc4b33171030970fa2fbe1ca1 (patch)
tree9a227b9397ca4fa464165fc4836ba8dd22275202 /main/CMakeLists.txt
parent1152ec32b6086c153dc41da59c9c451aa4465995 (diff)
Base i2c master functions
Diffstat (limited to 'main/CMakeLists.txt')
-rw-r--r--main/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/main/CMakeLists.txt b/main/CMakeLists.txt
index cd90499..88abf60 100644
--- a/main/CMakeLists.txt
+++ b/main/CMakeLists.txt
@@ -17,6 +17,7 @@ add_executable(main
main.c
init.c
sock.c
+ i2c.c
)
pico_enable_stdio_usb(main 1)
@@ -29,6 +30,7 @@ target_include_directories(main PRIVATE ${CMAKE_CURRENT_LIST_DIR})
target_link_libraries(main
pico_cyw43_arch_lwip_sys_freertos
pico_stdlib
+ hardware_i2c
FreeRTOS-Kernel
FreeRTOS-Kernel-Heap4
mpack