aboutsummaryrefslogtreecommitdiff
path: root/main/CMakeLists.txt
diff options
context:
space:
mode:
authorLoek Le Blansch <loek@pipeframe.xyz>2024-05-28 11:28:22 +0200
committerLoek Le Blansch <loek@pipeframe.xyz>2024-05-28 11:28:22 +0200
commit25a4f905a3f93645aee79157f30867b287871163 (patch)
tree3f33d41965595cafe5cc0ae783840ffdd3ca27ba /main/CMakeLists.txt
parentf4868604384908a7477cbb4b544c6ee7aac2a883 (diff)
separate the i2c over tcp from puzzle bus libraries
Diffstat (limited to 'main/CMakeLists.txt')
-rw-r--r--main/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/main/CMakeLists.txt b/main/CMakeLists.txt
index 30685a4..6390d7c 100644
--- a/main/CMakeLists.txt
+++ b/main/CMakeLists.txt
@@ -7,7 +7,7 @@ set(PICO_BOARD pico_w)
include(lib/pico-sdk/pico_sdk_init.cmake)
include(lib/FreeRTOS-Kernel/portable/ThirdParty/GCC/RP2040/FreeRTOS_Kernel_import.cmake)
-include(../proto/include.cmake)
+include(../i2ctcp/include.cmake)
project(puzzlebox_main C CXX ASM)
@@ -33,7 +33,7 @@ target_link_libraries(main
hardware_i2c
FreeRTOS-Kernel
FreeRTOS-Kernel-Heap4
- puzbus
+ i2ctcp
mpack
)