aboutsummaryrefslogtreecommitdiff
path: root/client/CMakeLists.txt
diff options
context:
space:
mode:
authorLoek Le Blansch <loek@pipeframe.xyz>2024-06-05 16:32:46 +0200
committerLoek Le Blansch <loek@pipeframe.xyz>2024-06-05 16:32:46 +0200
commitd9093e3245f9619850cea391adcad1a12164d38e (patch)
treea28c8acd5735de423ee142afe29d218df23b873e /client/CMakeLists.txt
parent36a8f66aeee73e82f28b040ca304e55034f05644 (diff)
the large library cleanup
Diffstat (limited to 'client/CMakeLists.txt')
-rw-r--r--client/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
index b1cfbaf..7d492b0 100644
--- a/client/CMakeLists.txt
+++ b/client/CMakeLists.txt
@@ -8,10 +8,11 @@ set(CMAKE_EXPORT_COMPILE_COMMANDS 1)
set(CMAKE_BUILD_TYPE Debug)
add_compile_definitions(DEBUG)
-project(puzzlebox_client C CXX)
+project(pbc C CXX)
-include(../i2ctcp/include.cmake)
-include(../shared/pb.cmake)
+add_subdirectory(lib/mpack)
+add_subdirectory(lib/i2ctcp)
+add_subdirectory(lib/pbdrv)
add_executable(pbc
main.cpp
@@ -27,5 +28,6 @@ target_link_libraries(pbc
i2ctcp
mpack
readline # this is such a common library that I did not bother adding it as a submodule
+ pbdrv
)