aboutsummaryrefslogtreecommitdiff
path: root/client/CMakeLists.txt
diff options
context:
space:
mode:
authorLoek Le Blansch <loek@pipeframe.xyz>2024-05-28 11:53:06 +0200
committerLoek Le Blansch <loek@pipeframe.xyz>2024-05-28 11:53:06 +0200
commitb6abd84b9930ab398f0402058e56a480e80799cc (patch)
tree28644973e7ffadcc3306b1ff28df9340f28404e7 /client/CMakeLists.txt
parent25a4f905a3f93645aee79157f30867b287871163 (diff)
update readmes
Diffstat (limited to 'client/CMakeLists.txt')
-rw-r--r--client/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
index 73c703d..57a2447 100644
--- a/client/CMakeLists.txt
+++ b/client/CMakeLists.txt
@@ -3,7 +3,10 @@ cmake_minimum_required(VERSION 3.29)
set(CMAKE_C_STANDARD 11)
set(CMAKE_CXX_STANDARD 17)
set(CMAKE_EXPORT_COMPILE_COMMANDS 1)
+
+# enable debug features
set(CMAKE_BUILD_TYPE Debug)
+add_compile_definitions(DEBUG)
project(puzzlebox_client C CXX)