aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLoek Le Blansch <loek@pipeframe.xyz>2024-09-22 16:09:14 +0200
committerLoek Le Blansch <loek@pipeframe.xyz>2024-09-22 16:09:14 +0200
commitd90cecc758d3c348f3aedf9c6e45a13ba6a0b0c3 (patch)
tree1b24e7c0fac394ef5cf0d6538b5209b89e91f86e /CMakeLists.txt
parente185fe6bc6cbe9bc1e0694fc5b11650118eeef82 (diff)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e4f76a5..67c5607 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,9 +5,22 @@ set(CMAKE_CXX_STANDARD 20)
set(CMAKE_EXPORT_COMPILE_COMMANDS 1)
set(CMAKE_BUILD_TYPE Debug)
+find_package(SDL2 REQUIRED)
+find_package(cpr REQUIRED)
+
project(main C CXX)
add_executable(main
main.cpp
+ File.cpp
+ HTTPFile.cpp
+ LocalFile.cpp
+ Exception.cpp
+ FileReader.cpp
+)
+
+target_link_libraries(main
+ SDL2
+ cpr
)