aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLoek Le Blansch <loek@pipeframe.xyz>2024-10-26 17:26:36 +0200
committerLoek Le Blansch <loek@pipeframe.xyz>2024-10-26 17:26:36 +0200
commit6781cee55a4e7f232eae3e5f2a652045412339ae (patch)
tree2bfd37fd36f4513d24c076051c64ee07608ddcf6 /CMakeLists.txt
parentc101364d4aafe50807cf7c8a831fb66eade3fb7f (diff)
use cmake instead of make
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..98c41b3
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,17 @@
+cmake_minimum_required(VERSION 3.28)
+
+set(CMAKE_CXX_STANDARD 20)
+set(CMAKE_EXPORT_COMPILE_COMMANDS 1)
+set(CMAKE_BUILD_TYPE Debug)
+
+find_package(pugixml REQUIRED)
+
+project(main CXX)
+
+add_executable(main)
+
+add_subdirectory(backend)
+add_subdirectory(frontend)
+
+target_link_libraries(main pugixml)
+