aboutsummaryrefslogtreecommitdiff
path: root/src/libui_sdl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/libui_sdl/CMakeLists.txt')
-rw-r--r--src/libui_sdl/CMakeLists.txt18
1 files changed, 7 insertions, 11 deletions
diff --git a/src/libui_sdl/CMakeLists.txt b/src/libui_sdl/CMakeLists.txt
index 8c8467b..a3a7f8a 100644
--- a/src/libui_sdl/CMakeLists.txt
+++ b/src/libui_sdl/CMakeLists.txt
@@ -22,13 +22,12 @@ option(BUILD_SHARED_LIBS "Whether to build libui as a shared library or a static
set(BUILD_SHARED_LIBS OFF)
add_subdirectory(libui)
-find_package(SDL2 REQUIRED)
-include_directories(${SDL2_INCLUDE_DIR})
-#string(STRIP ${SDL2_LIBRARIES} SDL2_LIBRARIES)
+find_package(PkgConfig REQUIRED)
+pkg_check_modules(SDL2 REQUIRED sdl2)
add_executable(melonDS ${SOURCES_LIBUI})
-target_link_libraries(melonDS
- core ${SDL2_LIBRARIES} libui)
+target_include_directories(melonDS PRIVATE ${SDL2_INCLUDE_DIRS})
+target_link_libraries(melonDS core libui ${SDL2_LIBRARIES})
if (UNIX)
option(UNIX_PORTABLE "Make a portable build that looks for its configuration in the current directory" OFF)
@@ -38,12 +37,9 @@ if (UNIX)
find_package(PkgConfig REQUIRED)
pkg_check_modules(GTK3 REQUIRED gtk+-3.0)
- pkg_check_modules(SDL2 REQUIRED sdl2)
- target_include_directories(melonDS
- PRIVATE ${GTK3_INCLUDE_DIRS} ${SDL2_INCLUDE_DIRS}
- )
- target_link_libraries(melonDS ${GTK3_LIBRARIES} ${SDL2_LIBRARIES})
+ target_include_directories(melonDS PRIVATE ${GTK3_INCLUDE_DIRS})
+ target_link_libraries(melonDS ${GTK3_LIBRARIES})
ADD_DEFINITIONS(${GTK3_CFLAGS_OTHER})
@@ -63,7 +59,7 @@ if (UNIX)
elseif (WIN32)
target_sources(melonDS PUBLIC "${CMAKE_SOURCE_DIR}/melon.rc")
target_include_directories(melonDS PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}/..")
- target_link_libraries(melonDS comctl32 d2d1 dwrite uxtheme ws2_32 iphlpapi)
+ target_link_libraries(melonDS comctl32 d2d1 dwrite uxtheme ws2_32 iphlpapi gdi32)
endif ()
install(FILES ../../net.kuribo64.melonDS.desktop DESTINATION ${CMAKE_INSTALL_PREFIX}/share/applications)