aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index c92a21d..f35b3e9 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -6,6 +6,7 @@ add_library(core STATIC
ARCodeList.cpp
AREngine.cpp
ARM.cpp
+ ARM_InstrTable.h
ARMInterpreter.cpp
ARMInterpreter_ALU.cpp
ARMInterpreter_Branch.cpp
@@ -14,22 +15,39 @@ add_library(core STATIC
CP15.cpp
CRC32.cpp
DMA.cpp
+ DSi.cpp
+ DSi_AES.cpp
+ DSi_Camera.cpp
+ DSi_I2C.cpp
+ DSi_NDMA.cpp
+ DSi_NWifi.cpp
+ DSi_SD.cpp
+ DSi_SPI_TSC.cpp
+ FIFO.h
GBACart.cpp
GPU.cpp
+ GPU_OpenGL.cpp
+ GPU_OpenGL_shaders.h
GPU2D.cpp
GPU3D.cpp
GPU3D_OpenGL.cpp
+ GPU3D_OpenGL_shaders.h
GPU3D_Soft.cpp
NDS.cpp
NDSCart.cpp
OpenGLSupport.cpp
+ Platform.h
+ ROMList.h
RTC.cpp
Savestate.cpp
SPI.cpp
SPU.cpp
+ types.h
+ version.h
Wifi.cpp
WifiAP.cpp
+ tiny-AES-c/aes.c
xxhash/xxhash.c
)