aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..4b1149f
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,29 @@
+project(core)
+
+add_library(core STATIC
+ ARM.cpp
+ ARMInterpreter.cpp
+ ARMInterpreter_ALU.cpp
+ ARMInterpreter_Branch.cpp
+ ARMInterpreter_LoadStore.cpp
+ Config.cpp
+ CP15.cpp
+ CRC32.cpp
+ DMA.cpp
+ GPU.cpp
+ GPU2D.cpp
+ GPU3D.cpp
+ GPU3D_Soft.cpp
+ NDS.cpp
+ NDSCart.cpp
+ RTC.cpp
+ Savestate.cpp
+ SPI.cpp
+ SPU.cpp
+ Wifi.cpp
+ WifiAP.cpp
+)
+
+if (WIN32)
+ target_link_libraries(core ole32 comctl32 ws2_32)
+endif()