aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 4b1149f..a1110f1 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -13,9 +13,11 @@ add_library(core STATIC
GPU.cpp
GPU2D.cpp
GPU3D.cpp
+ GPU3D_OpenGL.cpp
GPU3D_Soft.cpp
NDS.cpp
NDSCart.cpp
+ OpenGLSupport.cpp
RTC.cpp
Savestate.cpp
SPI.cpp
@@ -25,5 +27,7 @@ add_library(core STATIC
)
if (WIN32)
- target_link_libraries(core ole32 comctl32 ws2_32)
+ target_link_libraries(core ole32 comctl32 ws2_32 opengl32)
+else()
+ target_link_libraries(core GL EGL)
endif()