aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorArisotura <thetotalworm@gmail.com>2019-06-04 15:53:08 +0200
committerGitHub <noreply@github.com>2019-06-04 15:53:08 +0200
commit97f4b5f70b67ea5cc142fbd1f3982c36b915a5d9 (patch)
treebd3fb3325db3743eef00cf3ddffafdeb644370a9 /src/CMakeLists.txt
parentf769d6e23f7635910e3f6659c6b55d8c6a8e96ff (diff)
parent3134c8fc66d1fbd5706930a3e3e64ce118406fe5 (diff)
Merge branch 'master' into fast-forward-hotkey
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 4b1149f..a1110f1 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -13,9 +13,11 @@ add_library(core STATIC
GPU.cpp
GPU2D.cpp
GPU3D.cpp
+ GPU3D_OpenGL.cpp
GPU3D_Soft.cpp
NDS.cpp
NDSCart.cpp
+ OpenGLSupport.cpp
RTC.cpp
Savestate.cpp
SPI.cpp
@@ -25,5 +27,7 @@ add_library(core STATIC
)
if (WIN32)
- target_link_libraries(core ole32 comctl32 ws2_32)
+ target_link_libraries(core ole32 comctl32 ws2_32 opengl32)
+else()
+ target_link_libraries(core GL EGL)
endif()