aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2076d30..d824f6f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -82,8 +82,10 @@ if (UNIX)
LINK_LIBRARIES(${GTK3_LIBRARIES})
ADD_DEFINITIONS(${GTK3_CFLAGS_OTHER})
-
- LINK_LIBRARIES("dl")
+
+ if (CMAKE_SYSTEM_NAME STREQUAL "Linux")
+ LINK_LIBRARIES("dl")
+ endif ()
endif (UNIX)
find_package(SDL2 REQUIRED)