aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 66d0461..8f89c31 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -121,6 +121,13 @@ if (ENABLE_LTO)
endif()
endif()
+find_program(CCACHE "ccache")
+if (CCACHE)
+ message(STATUS "Using CCache to speed up compilation")
+ set(CMAKE_C_COMPILER_LAUNCHER ${CCACHE})
+ set(CMAKE_CXX_COMPILER_LAUNCHER ${CCACHE})
+endif()
+
option(BUILD_QT_SDL "Build Qt/SDL frontend" ON)
add_subdirectory(src)