aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 67936ab..3283fb0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -94,6 +94,10 @@ if (WIN32)
option(BUILD_STATIC "Statically link dependencies" OFF)
endif()
+if (BUILD_STATIC AND WIN32)
+ set(CMAKE_FIND_LIBRARY_SUFFIXES .a)
+endif()
+
if (ENABLE_LTO)
if (WIN32)
add_compile_options(-flto)