aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorWaluigiWare64 <68647953+WaluigiWare64@users.noreply.github.com>2021-03-26 18:04:19 +0000
committerWaluigiWare64 <68647953+WaluigiWare64@users.noreply.github.com>2021-03-26 18:04:19 +0000
commit7e6cf61b4c2d4e1cf21183447a6b086eb6113188 (patch)
tree512de4c9e8e19a079020bdb1215e5f9884fd45a7 /CMakeLists.txt
parent2c2e868de0dfa95e1f6710f7c41be7a66a39783b (diff)
Fix static iconv linking on Windows
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 67936ab..3283fb0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -94,6 +94,10 @@ if (WIN32)
option(BUILD_STATIC "Statically link dependencies" OFF)
endif()
+if (BUILD_STATIC AND WIN32)
+ set(CMAKE_FIND_LIBRARY_SUFFIXES .a)
+endif()
+
if (ENABLE_LTO)
if (WIN32)
add_compile_options(-flto)