aboutsummaryrefslogtreecommitdiff
path: root/src/frontend/qt_sdl/CMakeLists.txt
diff options
context:
space:
mode:
authorNadia Holmquist Pedersen <nadia@nhp.sh>2020-05-06 02:36:47 +0200
committerNadia Holmquist Pedersen <nadia@nhp.sh>2020-05-06 03:22:30 +0200
commit6cfe4faa56f4c7c34bf42cd600c66a2ed7966062 (patch)
tree646d0020a9c1c41cd3ef963e0a5e377c91f1abc6 /src/frontend/qt_sdl/CMakeLists.txt
parentffe20c1236d4f8140d25c7548ab452e7b35064bd (diff)
Use Qt abstractions for file I/O and threading on both Windows and Linux.
Diffstat (limited to 'src/frontend/qt_sdl/CMakeLists.txt')
-rw-r--r--src/frontend/qt_sdl/CMakeLists.txt13
1 files changed, 8 insertions, 5 deletions
diff --git a/src/frontend/qt_sdl/CMakeLists.txt b/src/frontend/qt_sdl/CMakeLists.txt
index f03cad2..0b39a1c 100644
--- a/src/frontend/qt_sdl/CMakeLists.txt
+++ b/src/frontend/qt_sdl/CMakeLists.txt
@@ -17,6 +17,7 @@ endif()
find_package(Qt5 COMPONENTS Core REQUIRED)
find_package(Qt5 COMPONENTS Gui REQUIRED)
find_package(Qt5 COMPONENTS Widgets REQUIRED)
+find_package(Threads REQUIRED)
set(CMAKE_AUTOMOC ON)
@@ -27,22 +28,24 @@ add_executable(melonDS ${SOURCES_QT_SDL})
target_include_directories(melonDS PRIVATE ${SDL2_INCLUDE_DIRS})
target_include_directories(melonDS PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}/..")
target_include_directories(melonDS PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}/../..")
-target_link_libraries(melonDS core ${SDL2_LIBRARIES})
+target_link_libraries(melonDS core ${SDL2_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
if (UNIX)
- option(UNIX_PORTABLE "Make a portable build that looks for its configuration in the current directory" OFF)
- if (UNIX_PORTABLE)
- add_definitions(-DUNIX_PORTABLE)
- endif()
+ option(PORTABLE "Make a portable build that looks for its configuration in the current directory" OFF)
if (CMAKE_SYSTEM_NAME STREQUAL "Linux")
target_link_libraries(melonDS dl Qt5::Core Qt5::Gui Qt5::Widgets)
endif ()
elseif (WIN32)
+ option(PORTABLE "Make a portable build that looks for its configuration in the current directory" ON)
target_sources(melonDS PUBLIC "${CMAKE_SOURCE_DIR}/melon.rc")
target_link_libraries(melonDS comctl32 d2d1 dwrite uxtheme ws2_32 iphlpapi gdi32 Qt5::Core Qt5::Gui Qt5::Widgets)
endif ()
+if (PORTABLE)
+ add_definitions(-DPORTABLE)
+endif()
+
install(FILES ../../net.kuribo64.melonDS.desktop DESTINATION ${CMAKE_INSTALL_PREFIX}/share/applications)
install(FILES ../../icon/melon_16x16.png DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/16x16/apps RENAME net.kuribo64.melonDS.png)
install(FILES ../../icon/melon_32x32.png DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/32x32/apps RENAME net.kuribo64.melonDS.png)