aboutsummaryrefslogtreecommitdiff
path: root/src/frontend/qt_sdl/CMakeLists.txt
diff options
context:
space:
mode:
authorRayyan Ansari <rayyan@ansari.sh>2022-02-18 15:32:46 +0000
committerArisotura <thetotalworm@gmail.com>2022-03-07 21:08:54 +0100
commit2569c67a13a6ce855d27821cc6863ebea82c429d (patch)
tree6eb326bfadb2dc28999bb722731c006c4dc327f9 /src/frontend/qt_sdl/CMakeLists.txt
parentc3adf6f606c694221342111a850e7b76ac77a56d (diff)
Add support for changing the DS and DSi battery level
The DS battery level is configured via the SPI Power Management Device, and the DSi's is configured via the I2C BPTWL. Add support for changing these registers and add the "Power Management" dialog in the UI.
Diffstat (limited to 'src/frontend/qt_sdl/CMakeLists.txt')
-rw-r--r--src/frontend/qt_sdl/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/frontend/qt_sdl/CMakeLists.txt b/src/frontend/qt_sdl/CMakeLists.txt
index 8b29bae..ec88026 100644
--- a/src/frontend/qt_sdl/CMakeLists.txt
+++ b/src/frontend/qt_sdl/CMakeLists.txt
@@ -6,6 +6,8 @@ SET(SOURCES_QT_SDL
CheatsDialog.cpp
Config.cpp
EmuSettingsDialog.cpp
+ PowerManagement/PowerManagementDialog.cpp
+ PowerManagement/resources/battery.qrc
InputConfig/InputConfigDialog.cpp
InputConfig/MapButton.h
InputConfig/resources/ds.qrc