aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorArisotura <thetotalworm@gmail.com>2020-10-26 20:47:30 +0100
committerArisotura <thetotalworm@gmail.com>2020-10-26 20:47:30 +0100
commitfc922ffb14da3aa087a7eebeb55d09cf3b856e0d (patch)
tree68ad639693d7b97d286e71364ac796bfaaeefd7b /src/CMakeLists.txt
parent8d42b1c7d7466abf80a61ea51ee3006110c15b65 (diff)
parent49a96f41daa53ffa5dc4a46bdac4ee68f0b7eaee (diff)
Merge branch 'master' into dsi_camera
# Conflicts: # src/DSi_I2C.cpp
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt31
1 files changed, 22 insertions, 9 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 8839fc2..d6c3897 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -26,17 +26,12 @@ add_library(core STATIC
FIFO.h
GBACart.cpp
GPU.cpp
- GPU_OpenGL.cpp
- GPU_OpenGL_shaders.h
GPU2D.cpp
GPU3D.cpp
- GPU3D_OpenGL.cpp
- GPU3D_OpenGL_shaders.h
GPU3D_Soft.cpp
melonDLDI.h
NDS.cpp
NDSCart.cpp
- OpenGLSupport.cpp
Platform.h
ROMList.h
RTC.cpp
@@ -52,6 +47,16 @@ add_library(core STATIC
xxhash/xxhash.c
)
+if (ENABLE_OGLRENDERER)
+ target_sources(core PRIVATE
+ GPU_OpenGL.cpp
+ GPU_OpenGL_shaders.h
+ GPU3D_OpenGL.cpp
+ GPU3D_OpenGL_shaders.h
+ OpenGLSupport.cpp
+ )
+endif()
+
if (ENABLE_JIT)
enable_language(ASM)
@@ -95,8 +100,16 @@ if (ENABLE_JIT)
endif()
endif()
-if (WIN32)
- target_link_libraries(core ole32 comctl32 ws2_32 opengl32)
+if (ENABLE_OGLRENDERER)
+ if (WIN32)
+ target_link_libraries(core ole32 comctl32 ws2_32 opengl32)
+ else()
+ target_link_libraries(core GL EGL)
+ endif()
else()
- target_link_libraries(core GL EGL)
-endif()
+ if (WIN32)
+ target_link_libraries(core ole32 comctl32 ws2_32)
+ else()
+ target_link_libraries(core)
+ endif()
+endif() \ No newline at end of file