aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorPoroCYon <pcy@national.shitposting.agency>2019-05-26 00:37:51 +0200
committerPoroCYon <pcy@national.shitposting.agency>2019-05-26 00:37:51 +0200
commit31e0f15797d0b6545ddc1a361252f267bf5d793d (patch)
tree0c85109357a0e64b72f6a80b16bcad67a399d54f /src/CMakeLists.txt
parent99dbbb0b0464d91ed07ffd67c0b6ef83bc6a293e (diff)
fix oudated CMake compile settings, add OpenGL dependency for Linux
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 4b1149f..72ae4bf 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -22,8 +22,13 @@ add_library(core STATIC
SPU.cpp
Wifi.cpp
WifiAP.cpp
+ # opengl backend stuff
+ GPU3D_OpenGL.cpp
+ OpenGLSupport.cpp
)
if (WIN32)
target_link_libraries(core ole32 comctl32 ws2_32)
+else()
+ target_link_libraries(core OpenGL)
endif()