aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorArisotura <thetotalworm@gmail.com>2021-08-24 17:46:20 +0200
committerGitHub <noreply@github.com>2021-08-24 17:46:20 +0200
commit235da420c8ac0bcec5a21db6f3cce4ae190fb7c5 (patch)
tree6aaacaa2b8c2f558601ea8321dd8141c8170f46c /src/CMakeLists.txt
parent346e8c0b878541d987d3ee2bfe54b555f626f7bf (diff)
having fun with fatfs (#1189)
* patch TSC coords in DSi mode * DSiware importer and shit
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index f604a39..54d0899 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -20,6 +20,7 @@ add_library(core STATIC
DSi_Camera.cpp
DSi_DSP.cpp
DSi_I2C.cpp
+ DSi_NAND.cpp
DSi_NDMA.cpp
DSi_NWifi.cpp
DSi_SD.cpp
@@ -46,6 +47,13 @@ add_library(core STATIC
Wifi.cpp
WifiAP.cpp
+ fatfs/diskio.c
+ fatfs/ff.c
+ fatfs/ffsystem.c
+ fatfs/ffunicode.c
+ fatfs/ffconf.h
+
+ sha1/sha1.c
tiny-AES-c/aes.c
xxhash/xxhash.c
)