aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStapleButter <thetotalworm@gmail.com>2017-04-30 03:46:27 +0200
committerStapleButter <thetotalworm@gmail.com>2017-04-30 03:46:27 +0200
commitee8d62188068bf49b0efa3b58b91e5a3e7580a19 (patch)
treedf8599e8e11f69911563f1d99584e4d19d5f5058 /CMakeLists.txt
parent1b06b2765d8d89b688beec9287526633280d40ee (diff)
finalize CMake shit.
Windows will stick to CodeBlocks until making a cross-platform build system isn't a total trainwreck under Windows.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 3 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7c5c6f2..3da4b2d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,14 +2,8 @@ cmake_minimum_required(VERSION 2.8.11)
SET(PROJECT_WX melonDS)
PROJECT(${PROJECT_WX})
-SET(APP_VERSION 0.1)
SET(INSTALL_PATH /usr/local/bin/)
-SET(VERSION ${APP_VERSION})
-
-CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/src/version.h.cmake
- ${CMAKE_CURRENT_SOURCE_DIR}/src/version.h)
-
SET(SOURCES
src/wx/main.cpp
src/wx/EmuConfig.cpp
@@ -30,10 +24,13 @@ SET(SOURCES
src/NDSCart.cpp
src/RTC.cpp
src/SPI.cpp
+ src/SPU.cpp
src/Wifi.cpp)
+if (UNIX)
find_package(GTK2 2.0 REQUIRED)
include_directories(${GTK2_INCLUDE_DIRS})
+endif (UNIX)
find_package(wxWidgets REQUIRED)
include(${wxWidgets_USE_FILE})