aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStapleButter <thetotalworm@gmail.com>2019-05-30 18:05:52 +0200
committerStapleButter <thetotalworm@gmail.com>2019-05-30 18:05:52 +0200
commitea669190aa5084a699590d2f2fed92e848a9fd53 (patch)
tree2f89668f951fe9da808241154293fb7b2a2d8f26 /CMakeLists.txt
parentce9d728fb6fe97a36eba5294a793f0d451c8fd6d (diff)
fix crash when using -O3.
gcc will try to optimize the memfill with MMX opcodes, but those seem to crash if the memory isn't aligned to a 8-byte boundary.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7daf1a5..38d4707 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,7 +21,7 @@ else()
endif()
if(ENABLE_LTO)
- add_compile_options(-O2 -flto)
+ add_compile_options(-O3 -flto)
endif()
add_compile_options(-fno-pic)