aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorArisotura <thetotalworm@gmail.com>2022-10-12 20:22:39 +0200
committerArisotura <thetotalworm@gmail.com>2022-10-12 20:22:39 +0200
commita83fbb65552e221642f3424097f378f0d905a926 (patch)
treef78b89099f0bf7e7da6352a42ba8605d466f8448 /CMakeLists.txt
parentb33f0434a6b4ca9b64ce7856ed12633ebf879cf7 (diff)
revert half of the change to build flags. it makes Teakra linking shit itself in a pretty bad and weird way.
sorry Nadia
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 223e808..2ef4f0d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -73,6 +73,8 @@ if (ENABLE_LTO)
set(CMAKE_INTERPROCEDURAL_OPTIMIZATION TRUE)
endif()
+set(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -Og")
+set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -Og")
string(REPLACE "-O2" "-O3" CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE}")
string(REPLACE "-O2" "-O3" CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE}")