aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn-Gee <john.ettedgui@gmail.com>2019-01-06 05:51:44 -0800
committerJohn-Gee <john.ettedgui@gmail.com>2019-01-06 06:00:06 -0800
commit5d364789afb0d653ff4eba3f6fa41a86aae071b6 (patch)
tree6e0bfa331e60bbe160f5655446b44dc31e3dc8b5 /CMakeLists.txt
parent64ab8302cb47856339eb765e1be46dec019c73ee (diff)
Fixed checking for build type
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2ac81aa..5944545 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -183,10 +183,9 @@ if(NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE Release)
endif()
-if(CMAKE_BUILD_TYPE EQUAL Debug)
+if(CMAKE_BUILD_TYPE STREQUAL Debug)
set(CMAKE_CXX_FLAGS "-g")
-endif()
-if(CMAKE_BUILD_TYPE EQUAL Release)
+elseif(CMAKE_BUILD_TYPE STREQUAL Release)
set(CMAKE_CXX_FLAGS "-O3 -flto")
endif()