summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorlonkaars <loek@pipeframe.xyz>2024-02-11 14:02:26 +0100
committerlonkaars <loek@pipeframe.xyz>2024-02-11 14:02:26 +0100
commit53bb457b7f86c2607c23616f1d14804a2b53292f (patch)
tree78c7c124afde4adbb29bfd595bb6af8f61a7ede5
initial commit (initial package)
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD24
-rw-r--r--psn-dp-1820.install12
4 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 0000000..9a5a45f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ppd-psn-dp-1820
+ pkgdesc = PPD drivers for Panasonic WORKiO DP-1520P, 1820E and 1820P
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://panasonic.net/cns/pcc/support/mfp/dp-1820/ps/download.html
+ install = psn-dp-1820.install
+ arch = any
+ license = unknown
+ makedepends = unzip
+ depends = cups
+ source = https://www.psn-web.net/cs/support/mfp/dp-1820/ps/mxae061215.zip
+ sha256sums = 7c3ccc9c8e8851aadb46b53108e92813f9b2751d61ce9e5727e2c26f49133b55
+
+pkgname = ppd-psn-dp-1820
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..341b195
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.zip
+*.tar
+*.sig
+
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..37b04ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Loek Le Blansch <loek@pipeframe.xyz>
+
+pkgname=ppd-psn-dp-1820
+pkgver=1.0
+pkgrel=1
+pkgdesc="PPD drivers for Panasonic WORKiO DP-1520P, 1820E and 1820P"
+arch=('any')
+url="https://panasonic.net/cns/pcc/support/mfp/dp-1820/ps/download.html"
+license=('unknown')
+depends=('cups')
+makedepends=('unzip')
+source=('https://www.psn-web.net/cs/support/mfp/dp-1820/ps/mxae061215.zip')
+sha256sums=('7c3ccc9c8e8851aadb46b53108e92813f9b2751d61ce9e5727e2c26f49133b55')
+install=psn-dp-1820.install
+
+package() {
+ cd "$srcdir/mxae061215"
+
+ target_dir="$pkgdir/usr/share/ppd/Panasonic"
+ mkdir -p "$target_dir"
+ install -D -m 644 \
+ Panasonic_DP-1520P.ppd Panasonic_DP-1820E.ppd Panasonic_DP-1820P.ppd \
+ "$target_dir"
+}
diff --git a/psn-dp-1820.install b/psn-dp-1820.install
new file mode 100644
index 0000000..2004307
--- /dev/null
+++ b/psn-dp-1820.install
@@ -0,0 +1,12 @@
+post_install() {
+ systemctl reload-or-restart cups
+}
+
+post_upgrade() {
+ systemctl reload-or-restart cups
+}
+
+post_remove() {
+ systemctl reload-or-restart cups
+}
+