summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlonkaars <loek@pipeframe.xyz>2021-09-17 18:45:51 +0200
committerlonkaars <loek@pipeframe.xyz>2021-09-17 18:45:51 +0200
commit4e2e83730fcaadd00773c9247eee3284b1f59a8d (patch)
treed9e8ffebcf97400a0c74dd6817122b99137f2c13 /PKGBUILD
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..ec6cae6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maitainer: Loek Le Blansch <loek@pipeframe.xyz>
+
+pkgname=arduino-language-server-git
+pkgver=1.0.0
+pkgrel=1
+epoch=1
+pkgdesc="An Arduino Language Server based on Clangd to Arduino code autocompletion"
+arch=('any')
+makedepends=('git' 'go')
+url="https://github.com/arduino/arduino-language-server"
+license=('APACHE')
+source=(git+https://github.com/arduino/arduino-language-server)
+sha256sums=('SKIP')
+provides=('arduino-language-server')
+conflicts=('arduino-language-server')
+
+pkgver() {
+ cd ${pkgname}
+ git describe --tags | sed "s+-+.r+" | tr - .
+}
+
+build() {
+ cd ${pkgname}
+
+ msg2 'Building...'
+ go build
+}
+
+package() {
+ cd ${pkgname}
+
+ msg2 'Installing executables...'
+ install -Dm 755 arduino-language-server -t "$pkgdir"/usr/bin
+
+ msg2 'Cleaning up pkgdir...'
+ find "$pkgdir" -type d -name .git -exec rm -r '{}' +
+}