diff options
author | lonkaars <loek@pipeframe.xyz> | 2021-09-18 11:02:28 +0200 |
---|---|---|
committer | lonkaars <loek@pipeframe.xyz> | 2021-09-18 11:02:28 +0200 |
commit | e166a33c4550df14c59a96433869b1a709a5f3b3 (patch) | |
tree | d6dcfbe52a734352831b29b7483a7a849c5d6bd1 /PKGBUILD | |
parent | caad6a22cb7eb33c1ebd4759e9ca0a8dfbc4e401 (diff) | |
parent | 4cf8e90bddedb80a4c3673b65d6edc5263880cf1 (diff) |
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 38 |
1 files changed, 21 insertions, 17 deletions
@@ -1,36 +1,40 @@ # Maitainer: Loek Le Blansch <loek@pipeframe.xyz> pkgname=arduino-language-server-git -pkgver=1.0.1 +pkgver=r239.134ca4d pkgrel=1 pkgdesc="An Arduino Language Server based on Clangd to Arduino code autocompletion" -arch=('any') -makedepends=('git' 'go') +arch=(x86_64 i686 i486 pentium4 arm armv6h armv7h aarch64) url="https://github.com/arduino/arduino-language-server" -license=('APACHE') -source=(git+https://github.com/arduino/arduino-language-server) -sha256sums=('SKIP') +license=('Apache') +makedepends=('git' 'go') provides=('arduino-language-server') conflicts=('arduino-language-server') +source=(git+https://github.com/arduino/arduino-language-server) +sha256sums=('SKIP') pkgver() { - cd ${pkgname%-git} - git rev-parse HEAD | cut -c1-7 + cd "${pkgname%-git}" + ( set -o pipefail + git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' || + printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" + ) } build() { - cd ${pkgname%-git} - - msg2 'Building...' - go build + cd "${pkgname%-git}" + go build \ + -trimpath \ + -buildmode=pie \ + -mod=readonly \ + -modcacherw \ + -ldflags "-linkmode external -extldflags \"${LDFLAGS}\"" \ + . } package() { - cd ${pkgname%-git} - - msg2 'Installing executables...' - install -Dm 755 arduino-language-server -t "$pkgdir"/usr/bin + cd "${pkgname%-git}" + install -Dm 755 arduino-language-server -t "$pkgdir"/usr/bin - msg2 'Cleaning up pkgdir...' find "$pkgdir" -type d -name .git -exec rm -r '{}' + } |