aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/api/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crepe/api/CMakeLists.txt')
-rw-r--r--src/crepe/api/CMakeLists.txt45
1 files changed, 35 insertions, 10 deletions
diff --git a/src/crepe/api/CMakeLists.txt b/src/crepe/api/CMakeLists.txt
index 0bb1263..e8d6f92 100644
--- a/src/crepe/api/CMakeLists.txt
+++ b/src/crepe/api/CMakeLists.txt
@@ -1,20 +1,31 @@
target_sources(crepe PUBLIC
- # AudioSource.cpp
+ AudioSource.cpp
BehaviorScript.cpp
- Script.cpp
GameObject.cpp
Rigidbody.cpp
- Force.cpp
ParticleEmitter.cpp
Transform.cpp
Color.cpp
- Texture.cpp
- AssetManager.cpp
Sprite.cpp
+ Config.cpp
+ Metadata.cpp
+ Camera.cpp
+ Animator.cpp
+ BoxCollider.cpp
+ CircleCollider.cpp
+ LoopManager.cpp
+ Asset.cpp
+ EventHandler.cpp
+ Script.cpp
+ Button.cpp
+ UIObject.cpp
+ AI.cpp
+ Text.cpp
+ Scene.cpp
)
target_sources(crepe PUBLIC FILE_SET HEADERS FILES
- # AudioSource.h
+ AudioSource.h
BehaviorScript.h
Config.h
Script.h
@@ -23,9 +34,23 @@ target_sources(crepe PUBLIC FILE_SET HEADERS FILES
GameObject.hpp
Rigidbody.h
Sprite.h
- Point.h
+ Vector2.h
+ Vector2.hpp
Color.h
- Texture.h
- AssetManager.h
- AssetManager.hpp
+ Scene.h
+ Scene.hpp
+ Metadata.h
+ Camera.h
+ Animator.h
+ BoxCollider.h
+ CircleCollider.h
+ EventHandler.h
+ EventHandler.hpp
+ Event.h
+ LoopManager.h
+ Asset.h
+ Button.h
+ UIObject.h
+ AI.h
+ Text.h
)