aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/api/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crepe/api/CMakeLists.txt')
-rw-r--r--src/crepe/api/CMakeLists.txt8
1 files changed, 2 insertions, 6 deletions
diff --git a/src/crepe/api/CMakeLists.txt b/src/crepe/api/CMakeLists.txt
index 46deb67..8f84f06 100644
--- a/src/crepe/api/CMakeLists.txt
+++ b/src/crepe/api/CMakeLists.txt
@@ -13,16 +13,14 @@ target_sources(crepe PUBLIC
Animator.cpp
BoxCollider.cpp
CircleCollider.cpp
- IKeyListener.cpp
- IMouseListener.cpp
LoopManager.cpp
- LoopTimer.cpp
Asset.cpp
EventHandler.cpp
Script.cpp
Button.cpp
UIObject.cpp
AI.cpp
+ Scene.cpp
)
target_sources(crepe PUBLIC FILE_SET HEADERS FILES
@@ -39,6 +37,7 @@ target_sources(crepe PUBLIC FILE_SET HEADERS FILES
Vector2.hpp
Color.h
Scene.h
+ Scene.hpp
Metadata.h
Camera.h
Animator.h
@@ -47,10 +46,7 @@ target_sources(crepe PUBLIC FILE_SET HEADERS FILES
EventHandler.h
EventHandler.hpp
Event.h
- IKeyListener.h
- IMouseListener.h
LoopManager.h
- LoopTimer.h
Asset.h
Button.h
UIObject.h