aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/api/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crepe/api/CMakeLists.txt')
-rw-r--r--src/crepe/api/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/crepe/api/CMakeLists.txt b/src/crepe/api/CMakeLists.txt
new file mode 100644
index 0000000..7b16fb1
--- /dev/null
+++ b/src/crepe/api/CMakeLists.txt
@@ -0,0 +1,17 @@
+target_sources(crepe PUBLIC
+ Image_asset.cpp
+ map_asset.cpp
+ Audio_asset.cpp
+ spritesheet.cpp
+ resource_manager.cpp
+)
+
+target_sources(crepe PUBLIC FILE_SET HEADERS FILES
+ resource.h
+ Image_asset.h
+ map_asset.h
+ Audio_asset.h
+ spritesheet.h
+ resource_manager.h
+)
+