aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crepe/CMakeLists.txt')
-rw-r--r--src/crepe/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/crepe/CMakeLists.txt b/src/crepe/CMakeLists.txt
index cfa51fb..57c77be 100644
--- a/src/crepe/CMakeLists.txt
+++ b/src/crepe/CMakeLists.txt
@@ -1,21 +1,38 @@
+
target_sources(crepe PUBLIC
Asset.cpp
Sound.cpp
SoundContext.cpp
+ Particle.cpp
+ ParticleEmitter.cpp
+ ParticleSystem.cpp
+ SDLApp.cpp
ComponentManager.cpp
Component.cpp
ScriptSystem.cpp
+ PhysicsSystem.cpp
+ Transform.cpp
+ CollisionSystem.cpp
+ Collider.cpp
)
target_sources(crepe PUBLIC FILE_SET HEADERS FILES
Asset.h
Sound.h
SoundContext.h
+ ParticleEmitter.h
+ ParticleSystem.h
+ Particle.h
+ SDLApp.h
ComponentManager.h
ComponentManager.hpp
Component.h
System.h
ScriptSystem.h
+ PhysicsSystem.h
+ Transform.h
+ CollisionSystem.h
+ Collider.h
)
add_subdirectory(api)