aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crepe/CMakeLists.txt')
-rw-r--r--src/crepe/CMakeLists.txt15
1 files changed, 4 insertions, 11 deletions
diff --git a/src/crepe/CMakeLists.txt b/src/crepe/CMakeLists.txt
index ef2584e..497423e 100644
--- a/src/crepe/CMakeLists.txt
+++ b/src/crepe/CMakeLists.txt
@@ -6,14 +6,11 @@ target_sources(crepe PUBLIC
Particle.cpp
ParticleEmitter.cpp
ParticleSystem.cpp
- SDLApp.cpp
+ SdlContext.cpp
ComponentManager.cpp
Component.cpp
- GameObject.cpp
- Collider.cpp
- Rigidbody.cpp
- Sprite.cpp
ScriptSystem.cpp
+ RenderSystem.cpp
PhysicsSystem.cpp
Transform.cpp
Force.cpp
@@ -27,21 +24,17 @@ target_sources(crepe PUBLIC FILE_SET HEADERS FILES
ParticleEmitter.h
ParticleSystem.h
Particle.h
- SDLApp.h
+ SdlContext.h
ComponentManager.h
ComponentManager.hpp
Component.h
- GameObject.h
- GameObject.hpp
- Collider.h
- Rigidbody.h
- Sprite.h
System.h
ScriptSystem.h
PhysicsSystem.h
Transform.h
Force.h
CollisionSystem.h
+ RenderSystem.h
)
add_subdirectory(api)