aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crepe/CMakeLists.txt')
-rw-r--r--src/crepe/CMakeLists.txt24
1 files changed, 15 insertions, 9 deletions
diff --git a/src/crepe/CMakeLists.txt b/src/crepe/CMakeLists.txt
index 6633696..afaa74c 100644
--- a/src/crepe/CMakeLists.txt
+++ b/src/crepe/CMakeLists.txt
@@ -1,14 +1,18 @@
+
target_sources(crepe PUBLIC
Asset.cpp
Sound.cpp
SoundContext.cpp
- SdlContext.cpp
+ Particle.cpp
+ ParticleSystem.cpp
+ SDLApp.cpp
ComponentManager.cpp
Component.cpp
- GameObject.cpp
- Collider.cpp
- Rigidbody.cpp
ScriptSystem.cpp
+ PhysicsSystem.cpp
+ CollisionSystem.cpp
+ Collider.cpp
+ SdlContext.cpp
RenderSystem.cpp
)
@@ -16,16 +20,18 @@ target_sources(crepe PUBLIC FILE_SET HEADERS FILES
Asset.h
Sound.h
SoundContext.h
- SdlContext.h
+ ParticleSystem.h
+ Particle.h
+ SDLApp.h
ComponentManager.h
ComponentManager.hpp
Component.h
- GameObject.h
- GameObject.hpp
- Collider.h
- Rigidbody.h
System.h
ScriptSystem.h
+ PhysicsSystem.h
+ CollisionSystem.h
+ Collider.h
+ SdlContext.h
RenderSystem.h
)