aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crepe/CMakeLists.txt')
-rw-r--r--src/crepe/CMakeLists.txt22
1 files changed, 2 insertions, 20 deletions
diff --git a/src/crepe/CMakeLists.txt b/src/crepe/CMakeLists.txt
index 750a47d..3b05742 100644
--- a/src/crepe/CMakeLists.txt
+++ b/src/crepe/CMakeLists.txt
@@ -1,41 +1,23 @@
target_sources(crepe PUBLIC
Asset.cpp
- Sound.cpp
- SoundContext.cpp
Particle.cpp
- ParticleSystem.cpp
- SDLApp.cpp
ComponentManager.cpp
Component.cpp
- ScriptSystem.cpp
- PhysicsSystem.cpp
- CollisionSystem.cpp
Collider.cpp
- SDLContext.cpp
- RenderSystem.cpp
- DB.cpp
)
target_sources(crepe PUBLIC FILE_SET HEADERS FILES
Asset.h
- Sound.h
- SoundContext.h
- SDLContext.h
ComponentManager.h
ComponentManager.hpp
Component.h
- System.h
- ScriptSystem.h
- PhysicsSystem.h
- CollisionSystem.h
Collider.h
- SDLContext.h
- RenderSystem.h
ValueBroker.h
ValueBroker.hpp
- DB.h
)
add_subdirectory(api)
+add_subdirectory(facade)
+add_subdirectory(system)
add_subdirectory(util)