aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crepe/CMakeLists.txt')
-rw-r--r--src/crepe/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/crepe/CMakeLists.txt b/src/crepe/CMakeLists.txt
index 8323490..6633696 100644
--- a/src/crepe/CMakeLists.txt
+++ b/src/crepe/CMakeLists.txt
@@ -2,19 +2,21 @@ target_sources(crepe PUBLIC
Asset.cpp
Sound.cpp
SoundContext.cpp
+ SdlContext.cpp
ComponentManager.cpp
Component.cpp
GameObject.cpp
Collider.cpp
Rigidbody.cpp
- Sprite.cpp
ScriptSystem.cpp
+ RenderSystem.cpp
)
target_sources(crepe PUBLIC FILE_SET HEADERS FILES
Asset.h
Sound.h
SoundContext.h
+ SdlContext.h
ComponentManager.h
ComponentManager.hpp
Component.h
@@ -22,9 +24,9 @@ target_sources(crepe PUBLIC FILE_SET HEADERS FILES
GameObject.hpp
Collider.h
Rigidbody.h
- Sprite.h
System.h
ScriptSystem.h
+ RenderSystem.h
)
add_subdirectory(api)